
FreeCommander ~ Assorted Information

Here is a small collection of information about some procedures that you may 
find useful.  This information applies to FreeCommander version 2009-02a.
I highly recommend the use of Drive Variables, Virtual Drive Letter, and 
Alternate INI files --- they make my portable FC a snap to load up, ready to use 
for various tasks on different computers, without further tweaking.
The second section is not really a tutorial, it is only a collection of short notes, 
and you may be already familiar with much of this information from reading the 
help file, but perhaps you will find a useful tip or two.

granny  ____________  o-o

28 February, 2010
Updated 30 April, 2010
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Drive Variables for portable use ---
If you run FC from a portable drive, file links are broken when drive letter 
changes.  Using FC "variable" strings  instead of a hard-coded path lets FC find 
your files, regardless of the actual drive letter.
You can use a variable string when you assign programs and icons to  Favorite 
Tools custom toolbuttons, and when you configure FC to use your own external 
editor, viewer, and file-comparison programs; and WLX QuickViewer plugins.

  When you browse to select an item that can use a variable string,
the browser menu presents the options for
Start Drive  %FcSrcDrive%  and Start Folder  %FcSrcPath%

  Select desired program or file.

  To use the Drive Letter variable ---
in the Configuration Window address display,
carefully delete the drive letter and the colon.
Click browser icon next to address field, then click Start Drive to insert 
%FcSrcDrive%. The variable string replaces drive letter and colon.
(Or, type it in manually.  You can also manually edit the INI file.)

B:\_Pdq\_Office\kPad\kPad.exe
Becomes        FcSrcDrive%\_ Pdq\_Office\kPad\kPad.exe

  Use %FcSrcPath%  to replace all of the path including the folder
where the FC executable is installed

B:\_Pdq\FC\App\FreeCommander\Tools\FileSeeker\fseeker.exe
Becomes        FcSrcPath%\Tools\FileSeeker\fseeker.exe

  Now FC will be able to launch the item from any drive letter.
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Virtual Drive Letter for portable use ---
Some FC elements cannot use Drive Variables.  So, if you want Folder Tabs 
that always point to your usb drive, you can make a batch file to assign the 
same virtual drive letter to your drive on every computer you use (if that drive 
letter is not already in use.)  Try to pick a drive letter that will be unused on 
other computers.  I use B, computers with two floppy drives are very rare.

If you use a virtual drive letter, you don't have to use Drive Variables for custom 
toolbuttons and External Program assignments.
Do use variables if you think your letter won't always be available.

NOTE –  Administrative rights are not required for this procedure.

  Copy subst.exe (9kb) from Windows\System32 to a folder on your
usb drive so the subst command can use a relative path.

  Create the batch file to assign the virtual drive letter ---
In Notepad, type the command illustrated below, using your chosen Drive 
Letter.  Save to your portable drive as filetype "all files" and use extension 
.bat; such as bStart.bat

Code :

 Subst.exe B: \

  After using a shared computer, delete the virtual drive letter,
or the "unavailable" drive will still remain, annoying future users.
Create a second batch file to delete your virtual drive letter ---
In Notepad, type the following command, and save to your portable drive 
as a .bat file, such as bStop.bat

Code :
 Subst.exe /d B:

  Assign the drive letter ---
Double-click the first batch file to run it. (right click if you want to Edit)
The usb drive will show under the letter that Windows assigns, and also 
under the virtual drive letter assigned by the batch file.
Set up tabs (and optionally, toolbuttons and External Programs) to point 
to the virtual drive letter.

  On the next computer, run the batch file again to assign the drive letter.
Use that virtual drive letter exclusively for all activity on all computers;
Tabs, History, and other elements will continue to point to the usb drive
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Alternate INI Files for multiple setups ---
Custom Column Profiles can be saved for various column arrangements for 
files in Details mode.  Custom Layouts can be saved for many different pane 
and tab setups.  (see guides for Configuring Display Elements)

With alternate INI files, you can save multiple setups for everything.

You can have INI files for different toolbar setups, for different External 
Programs and WLX plugins, for color schemes, for anything you can find in the 
Settings configuration windows actually, and in endless combinations.

  Should   YOU    use multiple   /   alternate INI files?  
I have a number of reasons to do this ---

  I run FreeCommander from a portable drive on four computers,
so I need setups for different screen resolutions, especially fonts.

  A few favorite programs that I configured as "external editors" won't work 
on Vista 64-bit, so I need to use other editors on that computer.

  Dedicated INI files for each computer preserve tab assignments and 
history --- no more error message "directory xxxxx not found".

  I frequently change color schemes on home computers.
Work computer won't let me change color scheme from XP default.

  My video and audio projects need lots of special software, so dedicated 
Favorite Tools custom toolbars are important to me, but I want them out 
of the way when not in use.

  I like to experiment with new settings, without the work of re-creating 
original settings if I want them back.

If any of those ring your bell, consider setting up some more INI files.

  Alternate SHC files
When you create custom keyboard shortcuts, the SHC file that stores the 
custom configurations is automatically saved with the same name as the INI 
currently in use.
If you use multiple INI files, save copies of the new SHC file with the 
corresponding names, or paste new configurations into existing SHC files.
"Alternate" SHC files automatically load along with the corresponding INI.
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  Launching FC with alternate INI files
You can use the Run command, a shortcut .LNK file, or a batch file,
by using command-line parameter /ini=  like this:

Enter full path and filename of the EXE file, followed by a space,
then the parameter followed by the path and filename of the INI file

   If the INI is stored in the same folder as FreeCommander.exe,
you don't have to enter the path for the INI, just its filename
Portable users, remember, FreeCommanderPortable.exe is only the 
launcher.  FreeCommander.exe is stored in \App\FreeCommander\.

  If the INI is stored in a different folder, you must enter its full path

  If file or folder names include spaces, you must enclose the 
path/filename string in double quotation marks.  See third sample.

Sample strings:
B:\FC\FreeCommanderPortable.exe /ini=DeskGreyVid.ini

B:\FC\FreeCommanderPortable.exe /ini=B:\Test\LapBlu.ini

B:\FC\FreeCommanderPortable.exe /ini="Lap Trial.ini"

  To open Run command, press WIN key + R
Enter the string, click OK to launch FreeCommander.
(in XP, you can also open Run from the Start menu.)
(in Vista, it is buried in All Programs>Accessories.
  See Vista Help files for instructions to pin it to the Start menu)

  Shortcut file ---
Open the folder where you want to store the shortcut,
Right-click and choose New > Shortcut.
When the shortcut Wizard opens, enter the string.
Click Next, name the shortcut, click Finish.
If you want a different icon, right-click the new shortcut,
click Properties >> Change Icon.
Browse to and choose from a DLL, EXE, or ICO icon file.
If the drive letter changes for a portable drive --- as long as you don't 
move the shortcut file, Windows will usually (not always) still manage to 
reconcile the path and launch FC successfully. (custom icons must be 
stored on the portable drive as well.)
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  Batch file ---
 In Notepad, type the command START,
followed by a space and the string.
Save as filetype "all files" and use extension .bat,
such as DeskGreyVid.bat

 For a portable drive, if a hard-coded drive letter changes, the batch 
file will fail.  The batch file will need a “relative path”.
You can try this trick, it works for me ---
Delete the drive letter and colon, as in second string shown below. 
Eliminating the drive letter seems to make the path relative.
Save and run this "relative" batch file from your portable drive.
It should continue to work under different drive letters, as long as the 
folder structure remains the same.

Sample Batch strings:
START B:\FC\FreeCommanderPortable.exe /ini=DeskGrey.ini

START \FC\FreeCommanderPortable.exe /ini="Lap Trial.ini"

  For what it's worth
On a previous page, I described assigning a Virtual Drive Letter for a 
portable drive, by copying the tiny Subst.exe tool onto the drive, and 
invoking it with a batch file.  So this is what my batch file looks like:

Subst.exe B: \
ChDir B:\
START B:\FC\FreeCommanderPortable.exe /ini=LapBlue.ini

I use Bat To Exe Converter from www.f2ko.de  /    to convert many of my 
batch files to exe files.  This tool has the "ghost" option which hides the 
DOS console window.  It can also compile a custom icon into the exe, so 
I use color-coded icons for different FC setups. (IcoFX, cool tool!)
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Protect your settings ---
  Configuration armor
Before you start digging into creating new settings ----
Remember all the warnings about "no undo".
You can take steps to protect your settings from being destroyed.

  Before you start tweaking, make a backup copy of current INI file, saved 
to another folder, or with another name.  If you are  configuring Keyboard 
Shortcuts, back up the SHC file if one already exists.

  If you feel comfortable editing INI files, you can copy and paste just the 
sections you need to restore.  (An INI file is just a text file, nothing to be 
intimidated about, I promise.)

  Do NOT manually edit the INI file while FreeCommander is running.
  If you're doing a lot of configuration, you might want to do it in stages.
Periodically exit out of settings, go to menu Extras > Save Settings.
You might consider making another backup copy of the INI file right after 
you save settings.  You can keep a separate backup for each step you 
saved, and that might be useful if you want to back-track.

  If you delete something by mistake, you can back out of the settings 
window by clicking Cancel, or clicking the top corner X close button. 
Unfortunately, this will lose all the work you already did in the session.

  Most importantly, pay attention to the environment.
You must notice which list is active, which item is highlighted and active, 
and which configuration icon you are going to click.
If you are careless, you will assign incorrect settings, or accidentally 
delete something that took so much work to set up.
For example, if you click the "Defaults" button in Keyboard Shortcuts 
configuration window, ALL custom shortcuts in the current SHC file are 
destroyed, no matter how much weeping and pleading you do.

  Disaster Preparedness
After you have all your settings just right, you should save backup copies of 
your current INI and SHC files, just in case disaster strikes.
You’ll spend all that time and effort tweaking, and one day, when FC opens, 
you will see the default settings of a new installation because your INI got 
corrupted somehow.  I'll bet you didn't think a granny knew those words!
Prevent the pain --- Back it up.

.
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Bits and Pieces from Granny’s knitting bag

Here's a scenario to get your motor running ---

You have a folder with 10 subfolders, filled with 3,000 image files in mixed 
formats.  You want to send all the jpegs to Aunt Jenny.
In Windows Explorer, this could be a painful task.  FC makes it easy.

  Here is one way to do it ---

Select the main folder.
CTRL + B               or menu View > Flat View – files
Flat View displays all files from folder and subfolders in a single list.

Click on any jpeg file.
ALT + Num+           or menu Edit > Select Files With Same Ext
CTRL + S                or menu View > Only View Selected Files

With two mouse-clicks and three hotkey-presses, all your jpegs (and only the 
jpegs) are displayed.

  Here's another way to do it, using Flat View again

Select the main folder.
CTRL + B               or menu View > Flat View – files
CTRL + Y               activates the Quick Filter Bar text field at left end of the 
active pane's status bar.
Type the file extension with leading asterisk into the text field:   *.jpeg

With one mouse-click, two hotkeys, and some minimal typing, all the jpegs 
are displayed.

Zip them up, send them out, and wait for Aunt Jenny to send you a box of 
chocolate-chip cookies.

Start exploring the FC interface and commands, and learn more ways it can 
simplify file management, and maybe help you earn some cookies
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Mouseless Mobility
Moving around the interface ---

  ALT activates the main Menu.  Then use RIGHT Arrow or LEFT Arrow to 
scroll, or press the accelerator key for the menu name
F for File, E for Edit, D for Folder, W for View, X for Extras, H for Help.
Use arrow keys and Enter to choose a command from the drop-down.

  TAB toggles focus from one pane to the other (into currently active tab)

  CTRL + TAB cycles through tabs in sequence in the active pane.

  SHIFT + TAB toggles focus back and forth between the Tree and the File 
List in the current tab.
if you have a file or folder selected in the File List, press Shift + Tab to 
move the cursor focus to that item's parent folder in the Tree pane, then 
use arrow keys to navigate to other folders or subfolders.
Shift + Tab again to jump to the File List for the newly selected folder.

Keyboard Navigation in the Folder Tree ---
  UP Arrow and DOWN Arrow keys navigate up and down folder list

  RIGHT Arrow expand current folder if collapsed, else select child folder

  LEFT Arrow collapse current folder if expanded, else select parent folder

  SHIFT + Num *  fully expand the tree under currently selected folder
(avoid selecting root drive, it would take a very long time to expand.)

Keyboard Navigation in the Folder Tree or File List ---
  HOME  selects first item at top of displayed active pane
(in File List, often this will be the "double-dot" parent folder symbol).

  END selects the last file or folder in the active pane

  CTRL + HOME  go to Root Folder

  BACKSPACE  go to Parent Folder

Want to use CTRL + BACKSPACE to go to Root Folder ?
Enter the following line in the keyboard shortcuts SHC file.

actDirRoot=Ctrl+BkSp
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File Window Navigation Notes

going up the path ………

In the Tree or File List pane, to go up ---

  Use the small icons at right end of address bar
"Go to root folder", "Go to upper folder"

  Use "Hot Folder"
Hover mouse cursor over the Address Bar, click highlighted folder.

  Use Go-Up Strip
menu Extras > Settings > View >
set Width of Go Up Strip 0 to 10 pixels

Go-up strips appear on outer left and right borders of FC window;
click on corresponding strip to go to upper/parent folder.

In the File List pane, to go up ---

  Double-click the parent folder symbol (double-dot) at top left.
(Or, press Home key, then Enter.)

  Double-click any empty spot in the pane
Set FC to select only Filename to ease grabbing empty space.
In the INI file  [Form] section, add line   FullRowSelect=0

Or do it the standard (boring?) way ---

  ALT + T  or menu View > Tree ,
and click your way up and down the folders in the Tree.
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Opening Folders
A folder will open in the active tab unless the tab is locked.
While in the File List, Double-click a folder to open it in the active tab.

to open folder with Single-Click --menu Extras>Settings>Select

Middle -click a folder to open it in a new tab.

Open Drive Root with Shift + <drive letter>
Such as  SHIFT + C

Open folders from drive bar or combo-box list
Click & Pick.

OR, use ALT + F1 to activate the left list, or ALT + F2 for the right list,
then use Arrow and Enter keys to choose a drive.

To configure how drive bar / combo-box opens folders
go to menu Settings>View>Drives>>Show With Drive Select
as Root folder, as Last-Visited Folder, or Same as other pane

Open folders from Folder Browser.
menu Folder > Search or hotkey SHIFT + F7 opens a browser window for 
the entire computer directory
menu Folder > Go To Folder --- enter a path manually, or click browse icon 
for the computer directory

Open folders by editing address bar.
ALT + G or right-click address bar and choose "Edit", manually type a path.
Or right-click, choose "Paste from clipboard" to paste in a copied path.
Choose "Copy to clipboard" If you want to use this address elsewhere, then 
Paste into the target address bar in another tab or pane.

For more copying options, right-click the small "Copy Path" icon at the right 
end of the address bar.

Assign folders to Favorite Folders list, or to a Favorite Tools toolbar
To assign a Favorites folder, go to menu Folders > Favorites > Edit,
To open a Favorite, select from the Favorites list, or use hotkey
(guide for Display Elements > Saving Setups has more about Favorites.
Operating Elements > Custom Toolbars describes assigning buttons)
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The Integrated Viewer
This feature lets you view supported files without having to open them in their 
associated program.  It can display plain text, rich text, many image formats, 
html (using Internet Explorer), and uses Windows Media Player to play 
supported mulitmedia files.

  F3  or menu File > View  opens the FC Viewer in an external window and 
displays the selected file.

  CTRL + Q  or menu View > Quick View  opens the FC Viewer in the 
inactive pane and displays the selected file.
(Quick View will also display folder information if a folder is selected.)
TIP--- you can copy text from QuickView pane, paste into a document

  If the file is not a supported format, it is displayed in Binary code.

  To configure viewer settings, select a file, open the external viewer, go to 
menu Options > Configure
Or, in Quick View mode, right-click Quick View title bar, select Settings
See the FC Help file for all the details.

  If you like, you can use a third-party viewer for the External view window.
AT   /   Universal Viewer   is recommended, and it supports WLX plugins.
Go to menu Extras > Settings > Programs >> External Viewer to assign 
your chosen viewer.

  For file formats not supported by the Viewer, try WLX “Lister” plugins 
(designed for Total Commander, but they can work in FreeCommander)

totalcmd.net.  ghisler.com.
See this wiki entry for known issues with some plugins, the information 
applies to the FC viewer as well as the AT Universal Viewer.

My own experience with Lister plugins has been mixed.
Some work wonderfully well, some are usable but have glitches, some 
refuse to work for me at all.  For some, success seems to depend on 
installed programs, even though authors don't state that in readme files.
My greatest interest is to use them in the Quick View pane, and very 
often they work well in the external window, but some not so well in Quick 
View.
You will have to experiment, I'm afraid.
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Flat View
  CTRL + B  or menu View > Flat View - Files

  SHIFT + CTRL + B   or menu View > Flat View - Folders

Flat view shows all items from the parent and subfolders in a single list.
(On slow computers, loading large numbers of files can be very slow.)

Flat View is applied only to the current folder, and is dismissed when you 
select a different folder or tab in the current pane.

I find it to be quite useful when used with specified Selections (such as the 
example in first section of this document), or in conjunction with a Defined 
Filter or Quick Filter.
You can, of course, locate the same list of files with Search Function, but 
the functions available from the search results list are limited.
With a filtered or sorted Flat View you can work with the files directly in the 
active tab, and all FC functions are available to move, copy, re-name, pack 
into archives, etc.

TIP--- It seems only Quick Filter and Defined Filters work on a Flat View list.
Using Set Filter for "temporary" criteria gives me zero file names.
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Filtering
  CTRL + F  or menu Folder > Filter > Edit opens the Set Filter dialog.

You can filter for one or more file-types by entering file extensions
Separate multiple extensions with the leading dot,
such as    .txt.ini.log

Or you can filter for text strings in filenames
Strings must include an asterisk wildcard at the end,
such as    glitches*   or   *glit?s*

  For a "one-time use", enter the criteria in the top text field

  To save the criteria for re-use, you can name and define filters ---
In the Set Filter dialog, click Define button.  Click Add to List icon, name 
the filter, and in the text fields at bottom, enter Include & Exclude criteria.

  To display your list of defined filters,
press ALT + PageDown, or right-click Address Bar.
Select "All Files" if you want to disable the active filter.

NOTE –  This Filter does not include folder names in its action.
If you want to filter folder names, use the Quick Filter bar instead.
(see guide "Filters and Selections" for detailed discussion.)

Searching
  ALT + F7 (menu File > Search) opens FreeCommander Search dialog.

  CTRL + F7 opens the Windows Explorer Search dialog
Their interface is different, but features are similar:
Designate one or more folders or drives to search (multiple targets must 
be manually entered, separated with semicolon), select to search inside 
subfolders and inside compressed Archive files. You can use wildcards for 
filenames or for text to find inside files, Designate date ranges, attributes, 
size.  See Help file for all the details of FC Search function.

  Unique features:
FC Search can export a list of the items it found to a text file.
Windows "Save Search" saves your parameters in a file for future re-use.
(I wish FC could do that…)
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Packing & Unpacking compressed archives
FC can unpack Zip, Rar, CAB, and SFX (self-extracting) archives, pack files 
into Zip and CAB archives, and create SFX archives.

  ALT + F5  pack archives

  ALT + F6  unpack archives

  Or use the File menu or File # 2 Toolbar to call the functions.

 You can drag & drop a file or folder to add it to the archive.

 Double-click an archive to open it like a folder, and view files inside, 
rename, copy or delete them.

TIP--- Most files can be opened for editing in their associated program, 
such as opening a Word document in MS Word.
Although the program will allow you to do editing work, your changes 
won’t be saved to the archive,
BUT you can “Save As” to make another copy elsewhere, then drag 
that copy back into the archive to replace the original file.

 You can not drag a file out of an archive to extract it, but you can 
double-click to open the archive and display the contents, select the 
desired files, then invoke the Unpack function to extract just those files.

Please see Help file for the details of configuring and using these functions.
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Copying and Moving
  F5   Copy selected file/folder directly to current folder in the inactive pane
  F6   Move selected file/folder directly to current folder in the inactive pane

  CTRL + C  Copy selection (file, folder, text, image, etc)  to clipboard,
CTRL + X   Move selection to clipboard,
Click on target, CTRL + V to Paste

  Drag & Drop to another folder on the same drive by default Moves item
Drag & Drop to a different Drive by default Copies item

  Hold down CTRL key to force Drag & Drop to COPY item
Use SHIFT key to force it to MOVE item
Use ALT key to force creation of a LINK at the target
(you can use this to quickly add items to Favorite Tools custom toolbars)

  If you wish, you can disable Confirmation dialogs.
Go to menu Extras>Settings>Confirmations, and select "No Ask".

Deleting
  F8  delete selection to Recycle Bin

(Files can be restored from Recycle Bin)

  SHIFT + F8  delete without Recycle
(Files might possibly be recovered with third-party recovery tools)

  SHIFT + CTRL + F8  File Wipe / Secure Deletion with over-write
(Files cannot be recovered.)

  All deletion modes request confirmation.

I can't break my Windows habits, so I manually edited the SHC file that stores 
custom hotkeys with this line:  actFileShred=Ctrl+Del

So I use DELETE for delete to Recycler (Windows standard)
SHIFT + DELETE for delete without Recycle (Windows standard)
CTRL + DELETE  for File Wipe / secure deletion
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Renaming
To rename the selected file/folder,
use one of the following methods to enter editing mode :

  F2

  choose Rename command from File menu or right-click context menu.

  Select name to highlight it, click once gently to enter edit mode.

NOTE –  If you configured FC to Use Hot Tracking, or to Open files with 
Single Click, you will not be able to click the name for edit mode.
In these two cases, you must use F2 or the Rename command.

In the Rename dialog, enter the new name and/or file extension.
Unlike Windows, FC will NOT nag you about changing file extensions,
so be positive you know what you are doing.  :-)

If you prefer to edit names directly in the file list, disable the Rename dialog
in menu Extras > Settings > Confirmations.

If you have selected multiple files ---

  Right-click > Rename will edit only the focused name
(unlike Windows Explorer, which renames all the selected files to the new 
name, adding an incrementing number to each).

  Using F2 or Rename command automatically opens Multi-Rename if you 
have multiple files selected.

  The "official" way to open Multi-Rename is menu File > Multi-Rename
or CTRL + M
(see guide "Multi-Rename" for details of usage.)

TIP--- Did you know?  Windows Explorer won't let you name items with leading 
spaces or dots, but will accept them after you name them in FC or other utility.

If you use the FC Rename dialog, you cannot use a leading space,
but I found that editing directly in the file list does allow that.
So if you want leading spaces, disable the dialog.

In FC, if you choose "Alphabetical" sorting in menu Extras > Settings > 
View, leading spaces and leading dots will be considered in the sort 
sequence, and appear first.
If you choose "Natural" sorting, they are ignored.
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