
FreeCommander ~ Configuring Display Elements

FreeCommander is very flexible, allowing configuration of most interface 
elements.  It is perfectly usable by leaving all settings at default, but you would 
be missing out on some excellent features.
These guides discuss some of the options for working with the interface in 
FreeCommander version 2009-02a.  I hope they help you to create a 
comfortable environment, tailored to your needs.

granny  ____________   o-o
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updated 30 April, 2010
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The Splitter Bar
FreeCommander is designed as a dual-pane file manager, supporting multiple 
tabs in each pane, with independent view options.
Dual panes ease file organization, permitting drag & drop from one to the other, 
and simplify access for folder comparison and synchronization.

The splitter is the adjustable separator bar between the two panes, and you will 
probably be using it a lot to re-size them.

  Splitter Bar Configuration ---
Go to menu Extras > Settings > View >> Splitter.

OR,
right-click the splitter bar,
select Settings from
context menu.

  Select command icons to display on the bar.
If you use any of these frequently, this display gives fast access.
Note the two pairs in the screenshot, only one of the icons can be 
displayed at a time.

Recycle Bin provides the same functionality as Windows Recycle Bin icon
GlitchNote –  Unconfirmed bug / behavior ---  New assignment of
Recycle Bin icon requires FC to close and re-open for the icon to allow 
drag & drop file deletion (context menu is active immediately).

Return to index o-o Page 2 of 20

Splitter Bar
Context Menu



  Swap Panels Button – select if you want the button visible.
Swap Panels swaps the two current tabs to opposite panes.
GlitchNote –  even the maximum bar width of 12 pixels is too narrow to 
show Swap Panels button.  Command icons must be displayed in order 
to see the swap button.

  Set width of splitter –  set width from 3 to 12 pixels wide.
If you choose to display any of the listed command icons,
the bar width automatically increases to accommodate them.

  Splitter Bar Usage ---

  By default, the splitter is Vertical, with panes side by side.

To apply Horizontal split,
select the setting from View menu or splitter context menu.
Uncheck the setting to go back to Vertical.
Or, use hotkey CTRL + H to toggle between Horizontal and Vertical.

  Manually resize panes by Left-click and dragging the bar,

  Double-click the bar to force a 50/50 split.

  Choose from pre-set split proportions, such as 50/50, 25/75, etc.
  Go to menu View > Split Window >>  select a setting
  Or, Right-click the splitter, select a setting from the context menu.
  Or, use assigned or custom hotkeys.

  Disabling Panes ---
It is not possible in this version to permanently disable a pane.
The closest option is to apply a split of 100/0 %  or  0/100%.
Unfortunately, resizing the FC window brings the second pane back into 
view, and you must re-apply the split.  Use assigned or Custom hotkeys to 
make that easier.  (I assigned F9, simpler than the 3-key default.)
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Folder Tabs
Tabs make it possible to have multiple folders open in separate windows with 
independent View settings, all within a single interface.  If you like, you can 
keep dozens of tabs open for fast access to folders.

  Tabs Configuration  ---
Go to menu Extras > Settings  or hotkey SHIFT + CTRL + S
Select View >> Folder Tabs

OR,
right-click a tab;
select Settings from
context menu.

  Always keep one tab open.  Benefit: keeps context menu available.

  Enable tabs on multiple lines.   If not selected, when tabs exceed pane 
width, spinner arrows become available to scroll the tab list.

  Show drive character in tab.   You need it if you access multiple drives.

  Maximum length of tab title.   Set it to your preference.

  Mark locked tab with that character.   Type in your preference.

  Activate window when clicking its tab. It's safer to turn this on, to 
prevent accidental closures or file deletions.
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Tab Context Menu



  Close tab on double-click.   If not selected, cIose with middle-click.

  Keep current tabs if opening layout.   Turn this off if you want your 
applied Custom Layout to display its own set of tabs.

  Close all not locked tabs when program ends.

  Folder history per tab. This doesn't work correctly, known issue.

  Tab Colors.
 (see guide "Configuring Colors >> Interface Elements" for details.)

  Disabling Tabs ---
Uncheck "Always keep one tab open" and check "Close all not locked 
tabs when program ends".  Close any existing tabs.  That's it.

  Tab Usage ---
  Create a new tab ---  select the desired folder or drive.

 Go to menu View > New Folder Tab, or use hotkey CTRL + T.
  Or, right-click a tab and select New Folder Tab on context menu.
  Or, in the file list (not in the tree), middle-click a folder name

  Select / activate a tab
Click on tabs to activate them, or scroll the row using hotkeys ---
left-to-right with CTRL + TAB, right-to-left with SHIFT + CTRL + TAB.
When a tab label has focus, also scroll the row with mouse wheel.

  Copy tab to the other panel (creates new tab there) ---
right-click and select from context menu.  Or assign a custom hotkey.

  Display tab in other pane’s current tab (uses other tab’s View settings)
menu View > Same Folder or hotkey CTRL + E.

  Swap tab to the other pane (swaps the two current tabs, keeps settings)
menu View > Swap Panels or hotkey CTRL + U.

  Swap all tabs to opposite panes (keeps settings)
hotkey SHIFT + CTRL + U (FC command View~Tab:Swap Folder Tabs)

  Change a tab's position in the row ---
Select a Move option from context menu.  Or, simply drag & drop.

  Close a tab --- Middle-click the tab.   Or Double-click, if that is configured 
in Settings.  Or Right-click and select Close from context menu.
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  Locked Tabs ---
If you find yourself creating a tab for the same folder again and again, 
Locked Tabs are the thing for you.  When you return after visiting other tabs, 
or closing FreeCommander, your designated folder will always be waiting.

You can have different sets of locked tabs in different Layouts.

To Lock A Tab ---
Right-click the tab and choose a Lock option from Context Menu.
(or assign custom hotkeys for the Lock options.)
You can also change settings for existing locked tabs.

  Rename and lock ---
Use this option if you want to customize the tab name and colors.
The other lock options simply lock the tab.

This option will open a small editing window to configure the tab;
and automatically applies setting Lock – Navigation Enabled.

Enter a new name if you wish.

If you selected Gradient rather than 
Windows Colors in Tab Settings  ,   you 
can set unique background and font 
colors for each Inactive Locked Tab.
(Active colors apply to all tabs.)
Check-mark Tab color, and click 
color icons to create color settings.

TIP--- of possible interest --- you can also configure colors for a tab,
then unlock it, and it will retain the colors until it is closed.

  Lock – Navigation enabled ---
you can select other folders and drives,while remaining in the locked tab.

  Lock – navigation to subfolders ---
you can open subfolders, but going outside the main folder will open the 
new folder in a new tab.

  Lock – no navigation ---
selecting any other folder opens that folder in a new tab.
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File Display
Here is a freshly installed FreeCommander, a new chick just hatched from
its zip file.  At this point, panes show file list for C-drive and the installation drive 
letter.  File names display in List View mode, and there is no folder Tree.

  

  The Folder Tree enables navigation in the directory structure.
To toggle Tree display on and off in the active window / tab ---
go to menu View > Tree  or  View toolbar > Tree  or  hotkey  ALT + T.
The tree displays only the folder structure for the selected logical drive.
It is not possible in this version to display the virtual "Computer" structure 
that shows all drives as Windows Explorer does.  This feature may be 
available in future versions.

NOTE –  the Tree displays for each drive letter within a pane are tied to one 
another.  For example, with two tabs open in the left pane for 
C:\Program Files and C:\Temp, if you expand the folder tree in one 
tab, the tree will also expand in the second tab.
However, a tab in the right pane for C:\Program Files will display 
independently of the tabs in the left pane.

  The File List window can display files in List, Details, Thumbnails, Large 
Icons, or Small Icons, with or without a folder Tree.
You can have different file displays in each pane and each tab.
One tab might have Details with Tree, another Thumbnails with no tree, etc. 
(See the FC Help file for more information about File View options.)

NOTE –  In the File List, Sort mode and "Size of Folders" settings will apply 
to all tabs/folders in the current pane.
Column widths and applied Custom Columns affect all folders in the 
current pane that are in Details view.
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File display ~ Window options
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  To change the File List display ---

1.  Use View menu  >> select a display mode

2.  Use View toolbar buttons

You can set View toolbar to display buttons for Tree, List, 
Details Thumbnails, a Views dropdown list, and others
Go to menu Extras > Settings > Toolbar
Select the buttons you want to display for each toolbar.

3.  Use context menu - right-click any spot in file list pane that is NOT a 
filename.  Click View, and select from the list.

4.  Or, use assigned or custom hotkeys

  More File Display options ---

5.  Flat View  // use View menu, or hotkeys.
Displays all the items from selected folder and subfolders in a single list. 
Current tab only.  It can be slow with very large numbers of files.

6.  Sort by  // use View menu, right-click Context Menu, or hotkeys.
(in Details mode, also click on column headers.)
Sort settings will apply to all tabs/folders in the current pane.
If you want newly added files to remain at bottom of the list until view is 
refreshed (like Windows Explorer), choose Sort By:  Unsorted.

7.  _Toggle_  Only selected files  // use View menu, or hotkey CTRL + S
Current tab only.  (Look in the Edit menu for some Selection options.)

8.  Refresh  // use View menu, Context Menu, or hotkey CTRL + R
Updates the display in the active pane.
To update both panes, use Refresh All  hotkey SHIFT + CTRL + R 
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File Display ~ Global options ---

  These settings apply globally to all tabs and panes
Go to menu Extras > Settings  or hotkey SHIFT + CTRL + S
Select >> View

  Use long names  (un-check it if you need DOS 8.3 notation)

  Show Hidden files     Show System files     off by default
I turn these on and off frequently, so I added a button to a Favorite Tools bar  
for the  command "Show/Hide System & Hidden Files" so I can toggle them.

  Show files tooltip  and optionally  show for folder too
Helpful if you need fast access to file information.
Like Windows Explorer, even if you turn tooltips off, a tooltip-style box will 
display file and folder names if cut off by narrow columns.

  Show grid  applies a table grid to file list in Details view.
Grid color uses the main Windows "3-D object" interface color, so 
depending on your File List color scheme, it may be helpful, distracting, or 
outright ugly.  Try it out, and make your choice.
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  File filter for both lists (with Ctrl reverse)
If turned off, filter settings only apply to active pane.
Press CTRL while choosing a filter to force it to apply opposite of the 
setting.  See guide "Filters and Selections" to learn more.

  Width of Go-up strip  from 0 to 10 pixels
If set wider than 0 pixels, go-up strips appear on outer left and right 
borders of FC window; Cursor becomes "Link" (pointing hand) cursor;
click on corresponding strip to go to upper/parent folder.

  Sorting settings
Choose for Natural or Alphabetical sorting,
and how you want folder names sorted.

  Timestamp format
Select date & time format to display in File List, or type in your own.

  Status bar: File size in…      File list: File size in…
Select to display file sizes in Bytes, Kilobytes,
or use "Auto" if you want to see KB, MB, GB sizes.

TIP--- You can disable "Full Row Select"
Thus, only the file-name is selected, making it easier to grab "empty 
space" when navigating or using drag&drop.
In your FreeCommander INI file, [Form] section, add the line

FullRowSelect=0
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Thumbnails Configuration ---
  These settings apply globally to all tabs and panes
Go to menu Extras > Settings  or hotkey SHIFT + CTRL + S
Select View >> Thumbnails

  Thumbnail (frame) size in pixels, from 50x50 to 150x150 pixels.
(A thumbnail will not display larger than the original image.)

  Spacing in pixels ( X = horizontal, Y = vertical), maximum 100 pixels.

  Optimize display for Speed or for Quality

  Format selections – check file extensions for image formats to display.
 If you Select All, all supported images will display in thumbnails.
Unsupported image formats will not display.
 If you select some formats, excluded formats won't display.
 If you Select None, ALL files (not just images) will display thumbnails.
Unsupported file-types will use Windows generic icons for the image.

GlitchNote –  Active folder in thumbnall mode doesn't automatically update if 
format selections are changed.  Refresh is ineffective.  To force update, switch 
to another View and back to thumbnails.  Or, select another folder, and return.
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Saving Setups for Re-use
A very convenient feature of FreeCommander is the ability to save various 
setups to use again, with Custom Columns, Favorite Folders, and Layouts.
With a couple of mouse-clicks or press of hotkeys, you can instantly change 
your interface around to accommodate the task at hand.
Add to that the ability to save and use alternate INI settings files, and you can 
launch FreeCommander already optimally configured for different tasks and 
environments.  (If that piques your interest, see the "Recommendations"  guide 
to read about "Alternate INI files for multiple setups".)

Custom Columns ---
If you use Details mode frequently, you may want a little more flexibility than 
just using FreeCommander's default view.  You can create Custom Column 
profiles, to display different sets of columns in various sequences for special 
uses, and call them up again when you need them.

 When first installed, FC in Details mode by default shows columns for :
Name, Size, Modified Date, Type, and Attributes.
 Four additional column types are supported :
Extension, Path, Created Date, Last Accessed Date.
(other column types may become available in future versions.)
 Custom profiles will over-ride the FC "default" column set.
you may wish to create a profile to replace that default setup.
The first profile on the list will now be considered the default.
Put your most-frequently-used Profile setting at the top of the list.

  Custom Columns Configuration ---
Go to menu Extras > Settings > View  >> Custom Columns (profiles)
Or, menu View > Custom Columns  >>  Customize

Note configuration icons to add, 
rename, remove, and arrange 
Profile Names in the list

You can also designate a profile
to use as Default for Flat View.
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  Create a Profile
You must create a Profile before you can set up columns.
(you see, you first create the container, then put in the objects….)

1. Click Add To List icon.

2. Type the name in the new text-field.
(To edit an existing name, highlight it and click the Rename icon,
or highlight the name and click once to enter text-edit mode.)

3. With the entire profile row selected, click Define Columns icon
If text-field is active for editing, Define Columns icon is disabled.
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  Add columns to the Profile ---
A new configuration window displays for the selected profile name,
with icons to Add to list,  Remove from list,  Move Up / Down

NOTE –  Name column is already assigned in each new profile.
You can change Alignment and Width, but not its position on the 
list.  The Name column is always first, and it cannot be deleted.

1. Click Add To List icon, select a column type from the menu.

2. Use Remove From List to delete columns from the list.

3. Use the blue spinner arrows to arrange columns display sequence.

  Configure the columns ---
To configure a column, select the name in the list to highlight it  ---

4. Click Alignment dropdown arrow, and select Left or Right.

5. Set column Width, minimum 2 characters, maximum 200.

6. To change the existing column type ---
Click Content list arrow, and select another type from the list.

7. Select Autosize for Name Column if you want Name column to 
automatically adjust to accommodate the longest name.
The column will change dynamically as you open each folder.
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  To apply a Custom Column Profile  ---
go to menu View > Custom Columns >> select profile name.
(there are no alternate methods to apply column profiles.)

  You can apply different column profiles in each pane.

  Any column setting, including applying Custom Columns, and manually 
changing column width by dragging the heading margin, will apply to ALL 
tabs in the pane using Details view

NOTE –  Except for the Name column when it is set to AutoSize,
manual change to column width over-rides configured width setting.
The next time the profile is applied during the current FC session, 
columns display at the widths from the manual adjustment, even 
though the configuration window still shows the original setting.

 If the Profile is in effect when FC is closed,
the manual adjustment will remain in place upon re-opening.
 If the Profile is NOT in effect when FC is closed,
the original settings are restored upon re-opening.

TIP--- To force column width back to the original Profile setting
simply open and close the Custom Columns configuration dialog.
Original settings will take effect immediately.
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Favorite Folders ---
Frequently used folders can be saved to the Favorites list, to be opened on 
demand.  Favorites are somewhat of a cross between a shortcut and a setup.
What makes them differ from a simple shortcut is that you can define two 
folders to open simultaneously, in the active and the inactive pane.
I also have some Favorites which are single folders that open only in the 
Inactive pane --- they are targets for files I move or copy from the current tab.

 Favorites do not save display settings for the defined folders.  The folder(s) 
will open in the active/focused tab(s), and inherit the tab's current settings.

 FC provides hotkeys to open the first ten Favorites listed,
SHIFT + CTRL + 1…SHIFT + CTRL + 0.
NOTE –  the hotkey is assigned to the list position, not to the Favorite name.

These hotkeys are not configurable, but guide "Keyboard Shortcuts" 
discusses using a macro utility to use your own key combinations.

  To define a Favorite ---
Go to menu Folder > Favorites > Edit  or use hotkey SHIFT + CTRL + F.
OR,  hotkey ALT + UP Arrow, select Edit from the pop-up menu.

The folders in currently in focus in each 
pane are automatically loaded in the 
address fields.
Accept them, or click browser icons
to select others.
You can manually edit the address field.

You can also highlight an existing Favorite 
name, and define different folder(s) for it.

  Click Add to List icon, and type a name in the new text-field.

  Use Rename icon, or select name and click once to enter text-edit mode.

  Click Remove from List icon to delete a Favorite.

  Use the spinner arrows to re-arrange the list sequence
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  To quickly add Current Folder to Favorites list ---

Go to menu Folder > Favorites > Add Current Folder
or use hotkey SHIFT + CTRL + V

The folder name is automatically 
loaded in the text window.
You may edit it if you wish to create 
a more descriptive Favorite name.

  To load a Favorite ---
Call up the Favorites list from menu Folder > Favorites >
Or hotkey ALT + UP Arrow.

Then select from the list.

OR,
load a Favorite by using its hotkey.
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Layouts ---
If you repeatedly need certain pane. tab, and/or file display settings, you can 
create and save different layouts of the FC main window.

 Layouts save the settings for the size and position of the FreeCommander 
window, the size and orientation of the two panes (splitter position),
the current tabs (including internal file display modes, applied custom 
columns, and tree settings), Sort and Filter settings, and history records.

 Layouts don't save alternate sets of Favorite Folders or Custom Columns, 
configured External Editor/Viewer programs, WLX "Lister" plugins for the 
Viewer; nor colors, toolbars, drivebars, status-bar settings such as 
QuickFilter and Function Key bar; and others. (Use Alternate INI's for those.)

 FC provides hotkeys to apply the first ten layouts listed, ALT+1…ALT+0.
NOTE –  the hotkey is assigned to the list position, not to the Layout name.

These hotkeys are not configurable, but guide "Keyboard Shortcuts" 
discusses using a macro utility to use your own key combinations..

  To save a Layout of your current window arrangement ---

Go to menu View > Layout > Edit  or use hotkey CTRL + G

  Click Add to List icon, and type a name in the new text-field.

  Click Remove from List icon to delete a Layout.

  Use the spinner arrows to re-arrange the list sequence.

  To edit a name, highlight it and click once to enter text-edit mode.
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  To apply a Layout ---
Go to menu View > Layout >> choose from the list
Or, use the hotkey for that layout.

Remember that important option in  Extras>Settings>View>Folder Tabs ---
  If you want to keep the current tabs in place,
check-mark setting for Keep Current Tabs if Opening Layout.

  If you want to use the tabs that were saved in the layout,
un-check that setting.

  To restore the previous window arrangement ---
Go to menu View > Layout >> Restore
(You can assign a custom hotkey if you like)

Restore only goes back one step.
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