FreeCommander ~ Filters & Selections

When you must work with large file lists, Filters and Selections can be your
good friends.

You can use Filters to display specified file names and/or file types,

(Quick Filter can also do folders), and save some filter settings for re-use.
Unwanted files are out of sight, giving you more elbow room to work with the
files you need. (Plus, those hidden files are protected from undesirable
changes.)

You can use Selections to select designated folder /file names and/or file-
types for manipulation. Some of these settings can also be saved for re-use.

If you are adventurous, you can even combine using Filter, Quick Filter, and
Selections all at the same time. Be sure to buckle your seatbelt.

These guides apply to FreeCommander version 2009-02a.

If you've read some of my previous guides, you may have twinges of déja vu.
| hope that the expanded descriptions and additional bits will make reading
these pages worth your time and give you some helpful information

granny 00
15 April, 2010
Click a link to go to a page:
Quick Filter page 2
Filter page 7
Selections page 14
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Quick Filter

Filtering displays the items you specify, and hides the others from sight.

Quick Filter displays file /folder names that contain a single defined text string.

If you use a specific file extension, Folder names are included only if they have
dot separators and the final segment matches the file extension.

The Quick Filter "bar" is a small text-input field at right end of each status bar;
you can display it permanently, or call it when you need it.

Fields for the two panes are independent --- you might have one pane active
and one inactive, or have both active with different filter strings in each.

m Quick Filter Configuration ---

Go to menu Extras > Settings or hotkey CTRL + SHIFT + S
Select Quick Search / Quick Filter.

Quick filter

Quick filter bar always visible

[+] Auto wildcards

[] Action "Filter off" deactivate quick filter too
Deactivate filter for folder change

File list background color if quick filter active:
E |

QLWN -2

=N

. Quick filter bar always visible — text field displays for each pane.

If setting is off, you can use hotkey CTRL + Y to display Quick Filter field
for just the active pane; ALT + Y to close it.

NOTE — Changes to this setting need FC to restart for update.

Until you restart FC, you can use status bar context menu
to toggle the setting to quickly get the display you want.

2. Auto wildcards -- the search string can appear anywhere in the name.
If setting is off, names must begin with, or exactly match the string.
For normal use, it is probably best to have this setting ON.

(see also discussion of using actual wildcards below.)
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3. Action "Filter Off" deactivates Quick Filter too —
See guide "Filter > Filter usage" for regular Filter Deactivation.

== \When using Set Filter dialog, Address Bar context menu,
and keyboard shortcut command Folder - Filter pop-up menu:

If you apply a Defined Filter or "All Files" to both panes,
then Quick Filter is deactivated in both panes.

If you apply a Defined Filter or "All Files" only to active pane,
Quick Filter is not affected. (bug)

== Using menu Folder>Filter> filter list for active or both panes,
Quick Filter is not affected. (bug)

== |f this setting is active, keyboard command Folder - Filter Off
will not refresh File Lists and Address Bars. (bug)

I choose not to use this setting, because sometimes | want Quick Filter to
stay active while | apply a Defined Filter. Also, the bugs cause confusion.

4. Deactivate filter for folder change — Quick Filter is automatically
deactivated when you select a different folder.
If setting is off, Quick Filter remains active for every folder you open
in the current pane.

At any time, you can deactivate Quick Filter with hotkey ALT +Y,
or use the adjacent icon to toggle Activate /Deactivate Quick Filter.

NOTE - The icon images indicate the action that will be taken,
not the current state of the filter.

So while Quick Filter is active, the icon displays a red X
to indicate that clicking it will deactivate the filter.

- stuff iLs 4 Object(s) 1.31MB

Activate quick ﬁlter|

- %

Deactivate quick filter|
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Color Flag

5. File list background color if quick filter is active

While the filter is active, and there is text in the field,
File List background is changed to the Quick Filter color.

Default color is Windows Display "Tooltip" color.

You can click the "color" icon, and use the color palette /mixer
to choose or define a different color.

Be sure File List font colors are readable against the color you set.

NOTE — This color does not affect Stripes in the File List.
Stripes retain the color (if any) configured in
Settings > View > Colors/Fonts.
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== Some Quick Filter search string examples ---

With Auto Wildcards active ---

doc finds .DOC (Word) files (e.g. help.doc ) 2009.Docs.txt
DoctordJohn.mp3, (folders) My Documents, July.Docs.Backup

.doc finds .DOC (Word) files, 2009.Docs.txt, (folder) July.Docs.Backup

With Auto Wildcards inactive ---
doc finds DoctorJohn.mp3 NOT help.doc or My Documents
.doc finds .Document.List.txt NOT help.doc or 2009.Docs.txt
.Docs.Backup.July ~ NOT July.Docs.Backup

TIP-- You can use wildcards in the text string.
— Use * asterisk as a substitute for zero or more characters

— Use ? question mark as a substitute for a single character

= |f string contains wildcards, it must end with asterisk or file extension.
If you want unspecified extension, you can use syntax big* or big.¥*

= Using actual wildcards over-rides Auto Wildcards setting.

If the string begins and ends with an asterisk
the string can appear anywhere in the name

If string begins with a character or ? and ends with asterisk or file
extension, names must begin with or match the string

*.ipg (unspecified name, specified extension) finds all jpg files

*n?w*.jpg (name must include n?w and have jpg file extension)
finds New.jpg, KnownUniverse.jpg, green&white.jpg

*n?2w* (name must include n?w and have any file extension)
finds those jpg files and also, New Draft.doc, (folder) New Draft

*n?w.* (name must end with n?w and any file extension)
finds (folder) Old & New, Big-New.doc, but not New Draft.doc

n?w*.doc (name must begin with n?w and have doc file extension)
finds Now.doc, (folder) New.BackUp.Doc, but not Big-New.doc

n?w and n*w won't work, need ending asterisk or file extension added
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= Quick Filter Usage ---

= Display Quick Filter bar

- To display fields for both panes permanently,
select setting Quick filter bar always visible.

- To display fields for both panes for just this session,
right-click status bar for context menu, turn the setting on.

(Status bar context menu settings are not saved when FC closes.)

- To display field only for active pane, use hotkey CTRL +Y

= Activate Quick Filter

== Click the text field, or use CTRL + Y to put the cursor in the field.
(CTRL + Y selects existing text. ENTER to accept, or start typing.)

Filter becomes active as soon as you begin to type, and the
background color changes.

== OR, If field contains text you want to use, click Activate icon.

== Enter search string as discussed above.
You can manually edit the text field as needed.
Text remains in the field until you edit/erase it, or FC is closed.

== Only folder and filenames containing the search string will display.

= Deactivate Quick Filter
Use any of the following methods to deactivate the filter.

== |Jse the icon next to Quick Filter bar to deactivate it.
== Use ALT + Y to deactivate Quick Filter in the active pane.
== Erase all the text in the field.

— If you selected setting "Deactivate filter for folder change",
select another folder or tab in the active pane.

- |f you selected setting "Filter Off deactivates Quick Filter too"
applying a Defined Filter or "All Files" to both panes from
context menu or pop-up menu deactivates Quick Filter. (see above)
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Filter

When you need more flexibility than Quick Filter offers, try the regular Filter.

This more complex filter lets you specify multiple text strings, file names,
and/or file-types. It is also possible to designate multiple exclusions.

This filter does not apply to folder names; use Quick Filter for that feature.

Filter criteria can be saved for re-use, so you can design and save customized
Defined Filters for any occasion.

m Filter Configurations ---

Color Flag
= Setting the address bar "Filtered" font color

While a filter is active in a folder/tab, the Address Bar text changes
to the “filtered" font color.

You can configure this in menu Extras > Settings > View > Colors/Fonts.
This is the only signal that a filter is in effect, so try to set a color
combination that is visible and memorable. Otherwise, you'll be
wondering why half your files have disappeared.

Address bar default color is green, "filtered" font default color is red.
(Inactive bar background uses Windows Display "Menu" color.)
Click the color icons to change background and font colors.

(see the "Configuring Colors" guides for more info on color tweaks.)

Folder Path - Inactive Panel

Folder Path Filtered - Active Panel
Folder Path Filterad - Thactive Panal

Hot folder Folder Path - Active Panel
Faolder Path - Inactive Panel

Folder Path Filtered - Active Panel

Hot folder Folder Path - Active Panel
c:\TEMP Folder Path - Inactive Panel

Folder Path Filtered - Active Panel
Folder Path Filtered - Inactive Panel

Hot folder
C:ATEMP\FreeCommanderiLNG
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= Setting the default for filter application

Quick search/filter Show grid
- Select items »[File filter for both lists (with Ctrl reverse)
- FTP 3 [#1] width of Go Up strip
= View :
.- Folder Tabs Sorting

Go to menu Extras > Settings > View
File filter for both lists (with Ctrl reverse)

This option sets default action for applying Defined Filter or "All Files"

from main menu Folder > Filter >> filter list, and from (custom)
keyboard shortcut command Folder — Filter pop-up menu.

== If the setting is on,
the filter applies to the current tab in both panes.

You can press CTRL while you select the filter, to force it to
apply only to the active pane.

- [f the setting is off,
the filter applies only to the active pane.
Use CTRL to force filter to apply to both panes.

This setting does not affect Address Bar context menu Filter List
(ALT + Pagedown). (bug)

The context menu Filter List always applies the filter
only to the active pane.

Use CTRL to force filter to apply to both panes.

This setting does not affect keyboard command Folder - Filter Off
(custom hotkey). (bug)

This command always applies "All Files" to both panes.
This behavior cannot be modified with the CTRL switch.

Because of the default behavior for the address bar context menu,
my personal preference is to leave this setting OFF.

So, no matter how | access the filter list, Defined Filters always apply only
to the active pane, unless | use CTRL to force them to apply to both panes.
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m Setting filter criteria ---

CTRL + F or menu Folder>Filter>Set Filter opens the Set Filter dialog.

b |

‘Set filter x|

Show only the followina files:
*audacity™;*.pdf ‘1 i~

E=ample 1: tatini.log
E=ample 2 &% exe* com

All files
Defined filter: 3

docs
scripts
web

video k

video
Include: .avi.m2v.mpg.vob
Exclude: *TS.vob:* _0.vob

se filter for both lists 2

Zox

= Set up and apply a "temporary" filter

1. Enter search string criteria in the top text field for files to display.
Use file names and/or file-types as discussed below.

NOTE — FC saves the ten most recent temporary filter strings.
Click the drop-down arrow to select from the history list.

NOTE — This usage has no option for Excluding files,
you must use a Defined Filter to get that feature.

2. Check or un-check "filter for both lists" to set which pane(s) to apply.

Click OK to apply the filter to the current tab(s).
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= Set up a Defined Filter

If you will want to re-use a filter string, save it in a Defined Filter.
Design and save as many filters as you like.

3. In the Set Filter dialog, click the Define button.

i |

‘Set filter X
Filter #1ab ¥ . W
docs

scripts
wieb

Example 1: .tstinilog
Example 2 4% exe;® com

I.r1::IL.||:|e:8 .avi.m2v.mpg.vob
Exclude: *TS.vob;*_0.vob

Files

[9«" oKk | [ X Cancel ] ’ App:_.r'o]

4. When new dialog opens, click Add to List icon, name the filter.

5. To edit an existing name, click Rename icon,
or select the name, then click it once to enter text-edit mode.

6. To delete an existing filter, click Remove from List icon.

7. To rearrange list, use spinner arrows to move names up/down.

8. In the text fields at bottom, enter Include and Exclude criteria.
You can also edit strings for existing filters.

9. Click OK to save without applying.

10. OR, click Apply to save and immediately apply the filter
to the current tabs

This usage always applies filter to both panes,
regardless of the setting File filter for both lists. (bug)
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= Some Filter string examples ---

= Fjlter for one or more file-types by entering file extensions.
If you are filtering for file-types only, you can list multiple extensions
separated with the leading dot, e.g.

txt.doc.odt.pdf.xls

== You can list file names, with or without wildcards,
separated by semi-colon.

Use asterisk wildcard as a substitute for zero or more characters.
Use question mark as a substitute for a single character.

Good.doc j Stuff.odt ; Bad?stuf®. txt

If you don’t include file extension, you must add an asterisk at the end.
good® ; ¥*bad® ;ugly?too®
== You can list file extensions in wildcard format together with filenames,
separated by semi-colon:
* .docj; *.pdf;MyPic.jpg;MySong.mp3;Stuf¥.txt

= |f the Include field is used, only those specified files are considered.
Use Exclude to refine the selections. e.g

Include .doc Exclude Bad.doc;*stuff*.doc.

== You can also use the Exclude field alone.

For example, with a folder full of images in bmp, jpg, gif, png, tga, and
tiff formats, you want to hide only the source PhotoShop psd files.

Instead of Including six file types, you only need to Exclude .psd.
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== Filter Usage ---

You can apply a filter to the current tab in active pane, or in both panes.

You could apply a different filter to each tab in each pane if you like.
(think of the possiblities for confusion!)

The filter will apply to every folder you open within that tab.
A new tab opened from within a filtered folder inherits the filter setting.

When you select a folder/tab with an active filter, the Address Bar text
changes to the “filtered” color. ( see above.)

Applied filters stay in effect until deactivated by using "All Files".
(Apply it by using the same methods as your Defined Filters.)

Active filters remain in place when FC closes and re-opens.
Active filters are also saved as part of custom Layout settings.

If you have multiple tabs with active filters, you must visit each one
to deactivate its filter. FC has no “global” deactivation command.

(added to my wish-list for “someday ....")

= To apply a "temporary" filter
Call Set Filter dialog with CTRL + F or menu Folder>Filter>Set Filter
Input criteria in top text field, OR, select from the history list.
Check or uncheck "filter for both lists" to set which pane(s) to apply.
Click OK to apply.

.~ File Edit |Folder | View Extras Help

& Change left drive Alt+F1
= Change right drive  Alt+F2

ﬁ [Hew F7
(g4 Search... Shift+F7
gl Go to folder...
2 Filter v ¥ Set Filter...  Ctrl+F
i +
S?ze of folders Alt+F3 v Al files (%)
History Alt+Down
_ docs
Favorites > .
. scripts
(Bl Make folder list...
web
(=1 Compare Alt+v video

Synchronize... Alt+5
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= To apply a Defined Filter

Use any of the following methods to apply a Defined Filter, including
"All Files" to deactivate a defined or temporary filter.

- Call Set Filter dialog ( CTRL + F or menu Folder>Filter>Set Filter )

Make sure the top text field is empty, any criteria in the top field will
over-ride the Defined Filters.

Check or uncheck option "filter for both lists" as needed.
Select a name in the Defined Filters list, click OK to apply.
Or click All Files button to turn off active filter.

— Go to menu Folder>Filter> ( keyboard ninja? ALT + D, then F )
Select a name from the Defined Filters list.

If you configured "Filter for both lists" in Extras>Settings>View,
the filter will automatically apply to both panes.

You can press CTRL while you select the filter name
to force it to apply only to active pane.

Conversely, if that setting for “both lists” is off,
CTRL will force the filter to apply to both panes.

- Use a custom hotkey for command "Folder — Filter"
(see guide "Configuring Operating Elements > Keyboard Shortcuts")

Select from pop-up menu, following same procedures as method 2.
== ALT + PageDown or right-click Address Bar for context menu.
Select from the Defined Filters list.

Default for this list is to appy to active pane only.
Use CTRL if you want to force it to apply to both panes.

extra If you love using hotkeys, you can try setting a custom hotkey for
keyboard shortcut command Folder-Filter Off, but it's a bit quirky.

It always applies to both panes, this behavior cannot be modified.

GlitchNote--,If Quick Filter setting Action "Filter Off" deactivates
Quick Filter too is active, Folder-Filter Off does not refresh the
File Lists and Address Bars,

You can force Refresh All with hotkey SHIFT + CTRL + R
( or configure a custom hotkey combination.

| stole CTRL+R from active pane Refresh, because

| usually want to refresh everything.)
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Selections

Filters display the files you ask for. Selections grab them for you,
so you can actually work with them, not just admire your spelling skillz. :-)

You're probably familiar with using Ctrl + A to Select All, and using the Shift or
Ctrl key with mouse-clicks to make multiple selections.

You can still use those, but FreeCommander has some handy options waiting
for you on the Edit menu.

NOTE - the selections and displays described below are not persistent,
they are dismissed if you select another folder in the current pane.

NOTE FOR LAPTOP USERS - default hotkeys for these commands use
number-pad keys. You might prefer to configure your own custom
hotkey combinations in menu Extras > Keyboard Shortcuts.

(see guide "Configuring Operating Elements > Keyboard Shortcuts)

'E Select all CtriH+A
Select all files Ctr+Num +
E Select group... MNum +
Select files with same ext. Alt+Num +
t Invert selection Num *

Invert selection - only files Ctrl+-iNum *
T* Unselect all Ctrl+Num -
T? Unselect group... Num -
Unselect files with same ext.  Alt+Num -
Select same in other panel
'tE' Save selection in file

'El Load selection from file

DETOUR =--- First, you should meet a valuable companion to Selections.
Hiding unselected files can make it easier to work with your file list.

You can use menu View > Only selected files or hotkey CTRL + S
to toggle between displaying selected files and all files.

(This command doesn't affect folders.)
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= Select all CTRL + A
Selects all files and folders in the active list.

= Select all files CTRL + Num =+
Selects all files in the active list.
This adds to current selection, so any selected folders remain selected.

= Unselect all CTRL + Num=—
This is self-explanatory, yes?

= Select group Num <+

In the Select Items dialog, enter text string in the Pattern field to designate
one or more filenames and/or file-types to be selected.

You can use wildcards. Separate multiple entries with semi-colon, as
described in guide "Filter > Filter Strings", second and third examples.

If you want to consider folders as well as files, you should use syntax
Name® or Name¥* . *. A specified file extension will ignore folder names,
unless the folder uses dot separators and final segment matches extension.

|

Select items m
FC saves a history list
Pattern of the ten most recent patterns for
*.doc; *.odt; *memo* (v Select Group and Unselect Group.

Dptions Click the drop-down arrow to select

1. &pply to folder, boo from the list.
2. &dd iternz to current selection
[] 2. within curent selection anly

| v oK | | X cancel

Default action creates a new selection of files, as specified by the pattern.

Use the Options to modify this behavior.
1. Apply to folder, too includes folder names in the selection.
2. Add items to current selection instead of creating new selection.
3. Within current selection only instead of the entire file list.

NOTE - For Option 3
If the pattern lists a single item, unmatched items are unselected.

Glitch- If the pattern has multiple entries, all items are unselected.
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= Unselect group Num —

In the Shrink Selection dialog, enter string to designate one or more
folder/filenames and/or file-types to remove from current selection.

Use the same syntax as for Select Group.

Shrink selection

This dialog shares the same history list

with Select Group.
* doc:*. odt *memo®
Click the drop-down arrow to select

ok ] from the list.

TIP-- Changing the sort order after using Select Group or Unselect Group
will unselect all items.

Change sort order before applying command.

OR,
apply command, then CTRL + S to hide unselected files, then sort.

= Select files with same extension ALT + Num+

Files with the same extension as the currently highlighted file
will be added to the current selection.

If you simply want to select only one file-type, such as all mp3 files,
select a single file before using this command.

= Unselect files with same extension ALT + Num=—
Files with the same extension as the currently highlighted file
will be removed from the current selection.

TIP--- The highlighted item has the focus.
With multiple files selected, look for the dotted "focus" rectangle.

If you want to change the highlighted file in a multiple selection,
use CTRL + UpArrow / DownArrow to scroll to the desired file.

OR,
CTRL + click desired file to unselect it, then CTRL + click to re-select it.
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= |nvert selection Num *

Currently selected files and folders are unselected
and unselected items will be selected.
If no items are selected, this command will Select All.

CTRL + Num ¥

= [nvert selection - only files

Currently selected files are unselected,
and unselected files will be selected.
Any currently selected folders remain selected.

= Select same in other panel

Select items in the inactive pane whose names match items in the current
selection. (it doesn't examine file sizes or dates, only names.)

Try these two commands if you must use the same files repeatedly.
For example, you may need to print daily reports from multiple databases,
or email frequently revised documents to a co-worker for collaboration.

= Save selection in file
Saves list of names of currently selected items into a .SEL file.

By default, it names the file with the current folder name and stores it in the
current folder. Change name and location as needed.

(The SEL file can be manually edited in a text-editor such as Notepad.)

= | oad selection from file
Creates a selection, based on the list stored in a SEL file.

In the File Open dialog, choose or browse to the desired .SEL file.

Available matching items will be selected.
Missing or re-named items are ignored, with no error message.
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