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FreeCommander ~ Multi-Rename

Using an organized naming system can make it easier to control your files.

For example, add a prefix to all files that belong to a certain project,
add incrementing numbers to track different versions of an evolving document,
add MP3 tags so you can finally get all that music categorized.
I grump about file extensions in UPPER case; Multi-rename fixes that easily.

Multi-Rename can add or replace text strings, change case,
 add incrementing numbers, insert many kinds of information into names
(date information, file Summary data, MP3 tags, photo EXIF data).

A supremely useful feature is the ability to create Profiles to save sets of 
parameters for future use.

Do keep in mind that some renaming operations are too complex to complete
in one step.  You might have to change parts of names in stages, and run 
Rename in two or more passes.

Currently, this function doesn't support wildcards, so sometimes you may need 
to use another utility that can find and replace unspecified text in filenames. 
(perhaps wildcards will be available in the future.)

But I do think you'll find that Multi-Rename meets your needs most of the time.
Try out the features, test different settings to see what they do.
With a bit of practice, you’ll soon be getting your file names under control.

The procedures in this guide apply to FreeCommander version 2009-02a.
I hope you find it helpful.

granny  ____________  o-o

15 March, 2010

Updated 30 April, 2010
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  SELECT FILES TO RENAME ---

With one or more files or folders selected in the File List,
go to menu File > Multi-Rename.  Or use hotkey CTRL +  M

A few notes about file selections ---

  Multi-Rename can only be called from the File List, not from the Tree.

  With multiple items selected, F2  or  File > Rename  will also 
automatically open the Muti-Rename dialog.

TIP--- To quickly load all files from the current folder, click to select Parent 
Folder "double-dot" symbol at top left of File List   (or press Home key)
Use F2 or File > Rename to load all files into Multi-Rename.

  In the Multi-Rename window, to expand current list to include subfolder 
contents,  select setting "With Subdirectories" on the right panel.
Subfolder names and filenames will load.

To exclude the subfolder names
leave With Subdirectories  checked,
and check "Files Only",

To show only contents of current folder,
uncheck With Subdirectories.

GlitchNote – for above setting - files in subfolders nested more than two 
layers deep will not load if Files Only is checked.  Confirmed Bug Report

You could leave Files Only unchecked, and manually remove folder 
names from list (use right-click context menu, or press DELETE key.)

OR, use Flat View instead ---
1.  CTRL + B or View > Flat View -Files

displays contents of current folder and its subfolders in File List.
2.  CTRL + A or Edit > Select All
3.  CTRL + M or File > Multi-Rename.

Note –  When Multi-Rename closes, Flat View is dismissed.
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1.  THE LIST WINDOW  displays the original name and the new name,
file size, modifed date,created date, and folder path.
"New names" update as you enter new parameters.  You can view 
results immediately and adjust settings as needed.
Status bar at bottom displays information for actions performed.
The dialog is resizable.  Drag column headings to change width.

  Right-click an item in the list to display Context Menu
This is your bail-out insurance to prevent unwanted changes to specified 
items.  Select an action from the context menu, or use its hotkey.

Activate Viewer          display in external window

Lock for Changes       lock to current display,
 block further changes

Edit and Lock         name item manually,
block further changes

Remove from List   the name keeps any completed rename operation
Properties               display Windows File Properties dialog
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TIP--- A Hidden Command  (it will be our little secret, ok?)

Use  CTRL + Q to toggle on and off a Quick-View window inside the 
Multi-Rename dialog.
This will display files in formats supported by the integrated viewer,
all others will display in Binary.
WLX Lister plugins don't operate in this window.

Drag the top border of the viewer window to re-size it vertically
drag the side borders of the dialog to re-size horizontally.
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2.  PATTERN --

Patterns are expressions that represent text
strings.  (think of them as named variables)
Use patterns to keep, discard,  replace, 
and/or append text in file names
Click  blue arrows to select from drop-down 
menu of available patterns.  You can :

  use characters from file Name,
file Extension, and/or containing Folder.

  use "Counter" to include
an incrementing number sequence.

  include date information, for current date,
file creation date, file modified date

  include information strings from
Summary, MP3, and EXIF lists

2-a  Counter
configure number sequence —
beginning number, size of steps,
number of digits to use.
Accept default settings,
type in numbers,
or use spinner arrows to increment

2-b  Timestamp format
accept default "Windows" format,
type in your own preferred format,
or select a format from drop-down list.
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  Enter pattern choices in the File Name field to change names.
Likewise, use the File Extension field to change the extension.

(In many cases, you'll probably simply type a new extension.)

  Pattern expressions are enclosed by square brackets [ ]
and will be replaced by their corresponding characters.

e.g. [n] is equivalent to all the characters in the name
[n5] is equivalent to the first five characters in the name
[n,3] is equivalent to the characters starting with the third.

Note that negative numbers count back from the right end of string
Use negative numbers when filenames have varying lengths,
and you want to work with characters at the end of the name.
See below for some pattern examples.

  Text without brackets will be inserted unchanged.
If you want to add other characters not derived from the patterns,
simply type them into the sequence, e.g. [n12]TopPick[n,13]
Be sure not to type inside the pattern brackets.
If you want to use square brackets in filenames, in combination with 
patterns, please see here.

  When you choose from pattern menu, expressions for Name, Extension, 
and Folder are entered into the text field with default settings of  1.
Replace with the desired numbers.

TIP--- If you will use a Counter incrementing number, first click a column 
heading to sort the list in the order you want numbers applied (by 
name, by date).  Then apply [c] Counter pattern in the text field.
Numbers stay assigned to those names even if you change the sort.
To change number assignments to a new sort order, clear [c] pattern 
from the text field,, and then enter it again.

3.  CASE ---
Select from the drop-down list
to choose a configuration,
or No Change.
If your desired combination isn't
listed, you can run rename twice
(you should Reset in between).
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4.  SEARCH AND REPLACE ---
  Enter one or more text strings to Search For

   Enter one or more text strings to Replace With
  Type a string and/or choose pattern expressions from drop-down 
menu  (click the  blue arrow.)
GlitchNote –Date Created and Date Modified are broken here.

  Leave Replace field empty to "erase" matched strings.

  You can search and replace multiple strings
by adding the pipe symbol  “| ” between the texts.

Example from help file:  (see below for more pipes examples)
Search For scattered vowels in the name by using this string:

a|e|i|o|u

Replace With CAPS by using this string:
A|E|I|O|U

favourites.doc  becomes fAvOUrItEs.dOc

  Replace All Occurrences applies to strings with and without pipes.
If it is checked, all occurrences matching the search string are replaced.
If it is not checked, only the first occurrence is replaced.

  If Ignore Case is checked, characters that match search string
will be replaced, regardless of their case.
If it is not checked, the search string case must be matched exactly.

5.  PROFILE ---
  You can save sets of parameters in Profiles, to be used again.
Click the icon next to the profile field  Save new profile
Enter a name in the input box.
To delete a profile, select it from the list, click icon Delete profile
You cannot re-name or re-configure an existing profile in the dialog.
(but you can manually edit the INI file.)

  On a related note, FC keeps a history of the ten most recent patterns
and text strings which you have configured.
Click drop-down list arrows to select from the history lists for
File Name, File Extension, Search For, and Replace With  fields.
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6.  THE COMMANDS ---

  Rename
The listed items will be renamed when you click Rename button,
except for any you have Locked.
If the option Close dialog after rename  is checked,
the window closes automatically if all the files have been renamed.

Items that can't be renamed are shown in red.
The most common causes for rename to fail ---

  the file is being used by another program
  another file already exists with that name in that location
   name contains "illegal" characters \ / : * ? " < > |   (see a fix here)

NOTE –  (unlike nagging Windows Explorer) read-only files are renamed 
without a question, file extensions changed without a quibble.
It’s a breath of fresh air.  But do be careful not to break your files.

  Undo
You can undo the last renaming operation.
If rename has just completed, and the Undo button is not active,
you must close and re-open Multi-Rename to activate Undo.
(you can use any file).

Click Undo, click YES on the confirmation dialog, then OK on the 
completion message.  Files are renamed in reverse order, last file first.
Don't panic when the dialog list doesn't show the recovered names,
it simply doesn't update for an undo operation.

  Reset
.Reset restores the initial default settings in all the text fields, including 
Counter and Timestamp format.
GlitchNote – if a Profile is in effect, timestamp format is NOT reset.

You may find it helpful to use Reset between passes when you must 
change names in stages.  Or any time you want a clean slate
Don't worry, Profiles and History lists remain unchanged.

  Close
All your current settings are stored when the dialog is closed,
and will be in place the next time you run Multi-Rename.
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  Patterns and Pipes can be a bit daunting at first, especially if you are
only accustomed to using * and ? wildcards to work with text strings.
Try the examples for practice, then create some settings of your own.

These are some pattern examples I snitched from the French Help file,
thank you BabelFish.  (it's not plagiarism, it's research !)

FreeCommander [n] FreeCommander All characters 
FreeCommander [n5] FreeC First 5 characters
FreeCommander [n-4] nder Last 4 characters
FreeCommander [n,5] Commander All characters

starting with fifth
FreeCommander [n,2,6] reeCom 6 characters

starting with second
FreeCommander [n,-3,5] mmand 5 characters ending

third from the end

This inserts a Counter incrementing number and a tilde to beginning of name.

Dog.avi,   Cat.avi [c]~[n] 01~Dog.avi,  02~Cat.avi

This adds some MP3 tags to the name.

Siciliana.mp3 [mp3artist]~[n]~[mp3comment]
Bach~Siciliana~Sonata#1031.mp3

This inserts a "manual" prefix to the name, adds a dash and date modified
(TimeStamp Format   mmyy), and changes file extension.

park.pspimage, Name  Kids-[n]-[dm] Kids-park-1109.psp
lake.pspimage Extension [e3]  OR  psp Kids-lake-0809.psp

Use a pattern like this one to replace character(s) at a specified location.
This example keeps the first three characters, inserts letter  F , then keeps the 
remaining characters from character 5 onwards.

510R-sumry.xls [n3]F[n,5] 510F-sumry.xls, 511F-sales.xls

You can use negative numbers to work with the end of the name.  This one 
keeps all characters ending with ninth from the end, skips 3, keeps the last 5.

Joe-11.01.10.odt [n,-9][n-5] Joe-01.10.odt, Billy-11.09.odt
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This Pipes example corrects mis-spelled words (and changes case).

Search for teh|lrod|rigs Replace with The|Lord|Rings

This one replaces abbreviations with full words.

Search for sumry|rpt Replace with Summary|Report

This one replaces "rpt" with two patterns, and erases the other string

Search for rpt|prelim usg Replace with [p12]-[d]|

How to add square brackets [ ] around a pattern.
Brackets typed between patterns double up in filename, and break the pattern.

In File Name, enter desired patterns.  Insert parentheses (or two other 
characters not existing in file names) where you will want brackets.

Name [n]([c])  CoolFile(06).jpg

In Search & Replace, replace parentheses with brackets

Search for (|) Replace with [|]

  Here is the final result. CoolFile[06].jpg

How to replace “illegal” filename characters < > : \ / * ? |  from MP3 tags.
Set File Name patterns for MP3 tags, then use Search & Replace strings 
similar to these . (use replacement characters that you prefer, of course.)
Note –  If tags include pipe symbols, those must  be edited manually.
Search for <|>|:|\|/|*|? Replace with -|-|~|_|_|#|x

Workarounds for Folder Names that use "dot" separators
e.g.   UFO.Sightings.1989,  UFO.Abductions.1992,  UFO.AbduHELLLPPP
FC interprets the final segment as a file extension.

  If you want to keep the dots, and want to edit characters in that final 
segment, you can use the Extension field to manipulate it.

  If you want to change dot separators (to tildes, for example), Search & 
Replace will fail on the final dot.  So you must get rid of the "extension" and 
append those characters to the "name".  Be sure to insert the new separator.
Name [n]~[e] Extension field must be empty
Search for . Replace with ~
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