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FreeCommander ~ Synchronize
Many of us use multiple drives, usb thumb drives, memory cards, iThings,
keeping digital data of all kinds on storage devices of all sorts.

So tell me quick, no hesitation, where's your last YouTube download?
Are you positive?
Have you spent an eight-hour workday editing an antique spreadsheet because 
the new one is on another drive 500 kilometers away?
Have you had a panic attack because you thought you deleted the only copies 
of your baby's first birthday pictures?  Has your mother-in-law  threatened 
homicide because you don't just think you did, you really did?

granny has a word of wisdom to whisper in your ear -----

Synchronize

FreeCommander provides a built-in function to protect you from those kinds of 
problems.  You can synchronize folders and files between different drives, and 
easily keep them updated and mirrored.  You can also use this function to 
make one-way simple backups and incremental backups.

This function doesn't identify files that have identical contents with different names.
For that sort of job, use a duplicate finder, such as Duplicate Cleaner (four thumbs 
up!),   CloneSpy ,  or  Easy Duplicate Finder  (I use old free version 2.4 portably)

Don't be intimidated.  Make up a few sample folders with some throw-away 
files, and run Synchronize a few times with different settings to get familiar with 
its behavior.  You'll soon be using it on a regular basis to help keep your data 
safe and organized.

The procedures in this guide apply to FreeCommander version 2009-02a.
I hope it is useful to you.

granny  ____________  o-o

20 March, 2010
updated 30 April, 2010
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http://www.easyduplicatefinder.com/
http://www.clonespy.com/
http://www.digitalvolcano.co.uk/content/duplicate-cleaner


  SELECT FOLDERS TO SYNCHRONIZE ---
Select "source" folder in the left pane, and "target" folder in right pane.
It won’t matter which pane is active, FC can tell its right hand from its left.

Go to menu Folder > Synchronize.  Or use hotkey ALT +  S

When the dialog opens, the file list window is empty.
You won't see filenames until you run Compare in Step 3.
List window has columns for Name, Directory, Date, Size, CRC (when used).

The dialog is resizable.  Drag column headings to change width.
Columns cannot be sorted  ( on my wish list --- sortable directory column…)

To change selected folders, click the browse icons at end of address bars.

If a filter is in effect when you open Synchronize, only the filtered files will be 
processed unless you change filter settings in Step 2.

Note that Quick Filter and "View Selected Files Only" have no effect here.
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1. CHOOSE COMPARISON CRITERIA ---
Criteria settings are saved, remaining in place until you change them.

  With Subfolders
Select this to include all subfolder contents in synchronization.
If not checked, only files in the parent folders are used.
NOTE –  Currently, FC can't include/exclude specific subfolders.

Your options are to
  open subfolders individually for synchronization
(you may find it helpful to use custom Layouts with Locked Tabs)

  Or, de-select files from the unwanted folders in Step 5.

NOTE 2 –  Empty folders are ignored, and excluded from the process.
  If you want to preserve folder structure during copying, you must 

keep at least one file as a “placeholder” in subfolders.
  Folders emptied by file deletion are not automatically deleted; this 

prevents a perfect "mirror".  You must delete them manually.

  With Hidden
This setting is off by default, turn it on at your own risk.  My personal view 
is that hidden files are usually hidden so they won’t be touched.

  By CRC  (checksum)
Files having the same checksum will be regarded as equal.
However, this method does not guarantee they are truly identical.

  By Content
Files with the same name are compared byte by byte, and are considered 
as equal only if their contents are absolutely identical.

  Ignore Date
If this option is selected, files with same name and same size will be 
regarded as identical.  See notes below for further discussion.

  Up to 2 sec ignore
This is useful when comparing FAT to NFTS  folders.
It can also help if you work at multiple computers, whose time may be a 
little out of sync.

  Ignore 1 hour time delay
You may find this useful if you're in an area using Daylight Savings Time.
Or if your computer times are really out of sync    :-)

Now that you’ve met the settings  and have an idea of what they do, take a look 
at the overview of the comparison process.
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 Some notes about the file comparison process
Files are examined in the following sequence:

1.  Compare file names

2.  If names are equal, then compare sizes.

3.  If sizes are equal, then compare dates.

4.  If dates are equal, or if Ignore Date setting is active, then:

A. If CRC/Contents setting is NOT selected, files are tagged as Equal.

OR,
B. If CRC/Contents setting IS selected, then compare CRC/Contents.

 If Checksum / Contents are equal,  then files are Equal.

 If Checksum / Contents are different,  then files are Unequal

But because dates are equal or Ignored, FC cannot identify the 
newer file, so it can't define copy direction.  You must manually 
select copy directions for Unequal files in Step 5.

You may have a specific reason to ignore the contents of files, and choose 
not to select By Content or By CRC.  For example, you may be doing a 
simple one-way backup to a new empty folder, and all files will be copied 
regardless of the settings.
But when synchronizing or backing up to existing folders, do consider 
carefully before setting criteria in this manner.

  If neither CRC nor Contents is selected, the function can only examine 
Name, Size, and Date.  As noted in 4-a above, files with same name,
size, and date will be considered equal, regardless of their content.

  If neither CRC nor Contents is selected, and Ignore Date is active,
the function can only compare Name and Size.
In this case, files with same name and size will be considered Equal.
Even if they have different dates and/or contents, those elements won't 
be examined.

In either of these cases, the file’s innards are not examined.  In an extreme 
example,  you could actually have a 200-kb Excel spreadsheet renamed to 
sales.txt, which would be considered equal to a 200-kb file named sales.txt 
that was written in Notepad.
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2. SPECIFY FILES TO COMPARE ---
In the FILTER section, you can specify file types and/or file names.
(but not folder names.)
Filter settings are not saved when Synchronize dialog closes.

  By default the fields are empty.
Include blank field = no filter = all files included, or *.*
Exclude blank field = no filter = no files excluded.

However, if a filter was in effect when you opened Synchronize,
the fields inherit those settings.  Change or clear them if you like.

  To use Defined Filters; click the Filter "funnel" icon to select from list.
to define filters, CTRL + F   or menu Folder > Filter > Set Filter

  You can manually enter file extensions, separated by leading dot, e.g.
.txt.doc.odt.pdf.xls

TIP--- you can enter file names separated by semi-colon,
with or without wildcards  e.g.
Good.doc;Stuff.odt;Bad?Stuf*.txt

You can use asterisk instead of extension   good*;*bad*;ugly*
You can't list "dot-separated" file extensions in the same filter field
with filenames, but you can include extensions in wildcard format :
*.doc;*.pdf;YourPicture.jpg

  If the Include field is used, only those files are examined.
Use Exclude to refine the selections.  e.g

Include   .doc Exclude   Good.doc;*stuff*.doc

  If Include field is left blank or *.*, then dot-separated file extensions in 
Exclude field are ignored, "Include All" over-rides those exclusions.
In this case, use wildcard format to list file-type exclusions   *.pdf

3. COMPARE THE FILES ---
Click the COMPARE  button.
With large folders, the process may take some time.
Results will display in the two lists.  Status bars display file counts.
If lists appear empty, you must Show Categories, see Step 4.

NOTE –  You must run Compare again If you change comparison criteria or 
filters, or if you go to the FC window and move, copy, or edit files.
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4. SPECIFY FILE CATEGORIES TO SYNCHRONIZE ---

Each file in comparison results list is assigned to one of six categories.
In the SHOW  section, Show or Hide a category by toggling its icon.
(Selected “active” icons are indicated by a simple outline.)

  Start by activating all the icons to see all the Comparison Results.

  Hide one or more categories to exclude those files from the process.
If you were to de-select all the category buttons, Synchronize would have 
no files to work with.

  Toggle category displays on and off temporarily to simplify file review and 
manual configuration in Step 5.

(New) Files existing only on the left side, will be copied to the right.
Filenames display in green.

(Modified) Files existing on both sides, copy newer file left to right.
Filenames display in green. Files to be over-written show strike-out.

Equal Files.  Identical files will not be copied.
Filenames display in black.
You'll’probably want to hide this group, to unclutter the results list.

Unequal files will not be copied automatically.
Filenames display in red.

You should display this group and review any unequal files,
otherwise some modified files might not be synchronized.
Unequal files are recognized as different, but no copy direction is 
defined.  FC cannot identify the newer file, because they have same 
date/time, or because Ignore Date setting was selected,
You must manually select the direction of the copy (see step 5).
If you make no selection, no action will be taken for unequal files.

(Modified) Files existing on both sides, copy newer file right to left.
Filenames display in blue. Files to be over-written show strike-out.

(New) Files existing only on the right side, will be copied to the left.
Filenames display in blue.
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5. MODIFY COPY ACTIONS FOR INDIVIDUAL FILES ---

In the RESULTS LISTS, you can change the default action for individual 
files by clicking the “action icon” next to filename, or by selecting an action 
from the Context Menu.

For example, you might need to assign copy directions for Unequal files, 
reverse copy direction to preserve an older file,
or de-select files in a subfolder to prevent them from being copied.

When you change a copy direction, the icon image changes, but filename 
“category colors” remain, and files stay assigned to their original category.
See the sample filename shown below---
it is assigned to the “Modified Left to Right” category.
When copy direction is changed Right to Left, filename is still assigned to 
original category.  If you hide that original category, the filename will be 
excluded from synchronize.

 “Remove selection” doesn’t take the name off the list, it only excludes that 
file from the synchronization process.

  “Action” icons can toggle through available copy options for the file.

− “New” files        default copy direction, or remove selection 
− “Modified” files     default copy, reverse copy, remove selection
− “Unequal” files      left to right copy, right to left copy

or default (“unequal” / no action) status

default copy direction

reverse copy direction

remove selection
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  The right-click Context Menu
provides copy actions,
plus some additional options.

Click to select an option,
or use its hotkey.

Note that options which don’t apply 
to currently selected file(s) are NOT 
disabled.  If you select an action 
that isn’t usable for that file, nothing 
will happen.

− Show File         view supported format with Integrated Viewer
− Show File (ext)     view supported format with External Viewer
− Compare left & right  use Compare Files* to examine two files

− Delete file         delete file to the Recycle Bin
− Properties         display Windows File Properties dialog

  To select all files in a category
right-click the category icon
for popup menu.

Also use SHIFT + Left-Click  or  CTRL + Left-Click to select multiple files.
With multiple files selected, you can use the context menu to apply action 
settings to the entire selection.
You can also delete the entire selection to the Recycle Bin. (careful . . .)

* Compare Files is another FC function, which uses a specified 
External Program to examine and compare text files in the File List.
This function is only available if you configure a program for it.

SHIFT + CTRL + S  or menu Extras > Settings.  Select Programs.

See here for some recommendations. (check this out-- WinMerge 
plugin  to work with MS Office, Open Office, rtf, pdf, mht, more)

If you need to go to the FC window to view, edit, copy, move files ---
Click on the FC window to bring it to top.
When finished, press ALT + S to bring Synchronize back to the top,
or click on any visible part of Synchronize Directories dialog.
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6. OPEN SYNCHRONIZE DIALOG ---
Click the SYNCHRONIZE  button.
This new dialog presents a summary of the files that will be processed.
Here you can make some additional configurations if you like.
You might, for example, want only to copy new files to target, and not over-
write older files with newer modified copies.
Copy/delete settings selected here will apply to the entire category.
Be cautious with these Delete settings, files cannot be recovered.
NOTE – emptied folders aren't deleted, you must remove them manually

  You can change target folders ---click browse icon, select a folder.
   A ---  For files existing only on one side, select to

copy (default), delete, or uncheck both to exclude from process.
   B ---  For files existing on both sides, select to

copy (default) or uncheck to exclude.

  If you want to make a one-way backup of only one folder,
select Asymmetric for the applicable side.

 This automatically disables the sync/mirror action.
Files will not be copied from target folder back to the source folder.

 If unique files exist in the target folder, by default they will be deleted.
If you want to keep those files, uncheck the delete option.
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  RUN SYNCHRONIZE ---
Ready?  Configurations all complete?  Deep breath . . . . . .  Click OK.
When copying finishes, close the main dialog.  Your work here is done.

  Odd Bits –
Synchronizing folders with 2 mouse-clicks and 6 key-presses
I have a number of folders I synchronize or back up, so I made a set of color-
coded locked tabs for source folders in left pane, and matching color-coded 
locked tabs for the target folders in right pane.  I saved these in a Layout.
I use the same settings for most backups, with no filter settings, so usually:

   ALT + 0  loads my layout

   I click the two red tabs

   ALT + S  opens main Synchronize Directories dialog
   two extra mouse-clicks here if I ever need a Defined Filter

   ENTER  to run Compare

   ENTER  to open Synchronize dialog
   extra mouse-click here when I want Asymmetric "one-way" Backup

   ENTER  to run Synchronize

   ESCAPE  to close main dialog

I click the two blue tabs, press ALT + S  . . . .      etc, etc.

Simple-ish method to delete empty folders
Try this to delete multiple empty subfolders, scattered in the folder structure:

   Select the parent folder

   SHIFT + CTRL + B  or menu View > Flat View > Folders

   ALT + F9  or menu Folder > Size of Folders to calculate folder sizes

   Choose "Details" view with a column for file size

   Click heading of Size column to sort by size

   Select and delete 0-byte folders

   SHIFT + CTRL + B again to toggle off Flat View, or select another tab

   ALT + F9  again to toggle off "Size of Folders"   (this calculation is quite 
CPU-intensive, it's recommended to only run it when needed.)
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